mvn packageでコンパイルエラー

mavenプロジェクトをコマンドプロンプトから

mvn package 

を実行するとコンパイルエラーになった。

エラー内容は下記の通り

[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] ソース・オプション1.5は現在サポートされていません。1.6以降を使用してください。
[ERROR] ターゲット・オプション1.5は現在サポートされていません。1.6以降を使用してください。
[INFO] 2 errors

Apache Mavenのリファレンスを読むとデフォルトで1.5だよって書いてある。
http://maven.apache.org/plugins/maven-compiler-plugin/index.html

エラーメッセージによると1.5はサポートされていないとのこと。
pom.xmlのpropertiesタグ内に下記のように記載。

<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>

再度、mvn packageすると無事BUILD SUCCESSしました。

ここのバージョン指定については後ほど調べて追記しようと思う。


2018/3/10追記
単純にJDKのバージョンということでした。。。